Dating with girls(2) HDU - 2579

Dating with girls(2)

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 
Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.
Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
Sample Input
1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.
Sample Output
7
题意;从Y点出发到G点“.”可以走,每走一步需要1,#在时间为k的倍数时才可以走。
思路:一个简单的广搜,就是标记不太好想,每一步总共有k种状态,所以book[tx][ty][step%k]标记,
其他的就是一个简单的广搜。
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
char map1[120][120];
int book[120][120][11];
int dis[4][2]={0,1,1,0,-1,0,0,-1};
int n,m,k,flag;

struct note
{
    int x;
    int y;
    int step;
};

void bfs(int x,int y)
{
    queue<note>Q;
    note p,q;
    p.x=x;
    p.y=y;
    p.step=0;
    book[p.x][p.y][p.step%k]=1;
    Q.push(p);
    while(!Q.empty())
    {
        p=Q.front();
        Q.pop();
        if(map1[p.x][p.y]=='G')
        {
            flag=1;
            printf("%d\n",p.step);
            break;
        }
        for(int i=0;i<4;i++)
        {
            int tx=p.x+dis[i][0];
            int ty=p.y+dis[i][1];
            q.step=p.step+1;
            if(tx<0||ty<0||tx>=n||ty>=m)
                continue;
            if(book[tx][ty][q.step%k])
                continue;
            if(map1[tx][ty]=='#'&&q.step%k)
                continue;
            book[tx][ty][q.step%k]=1;
            q.x=tx;
            q.y=ty;
            Q.push(q);
        }
    }
    return ;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&m,&k);
        memset(book,0,sizeof(book));
        int a,b;
        flag=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",map1[i]);
            for(int j=0;j<m;j++)
                if(map1[i][j]=='Y')
                a=i,b=j;
        }
        bfs(a,b);
        if(!flag)
            printf("Please give me another chance!\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值