【hdu】Dating with girls(2) (BFS,注意visit[i][j][k],可以重复走一个位置的)


Dating with girls(2)

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 4
Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
   
   
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
   
   
7
 

// 664.cpp : 定义控制台应用程序的入口点。
//


#include<cstdio>
#include<queue>
#define INF 0x3f3f3f3f
#define MAX 105
#define MEM(arr,w) memset(arr,w,sizeof(arr))
using namespace std;
struct node
{
	int x,y;
}st,ed,ss,tt;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int n,m,k,maxt;
char map[MAX][MAX];
bool visit[MAX][MAX][15];
int step[MAX][MAX];
bool judge(node tt)
{
	if(tt.x>=0&&tt.x<n&&tt.y>=0&&tt.y<m) return 1;
	return 0;
}
void Init()
{
	MEM(visit,false);
	MEM(step,0);
	maxt=INF;
}
void BFS()
{
	queue<node> Q;
	Q.push(st);
	while(!Q.empty())
	{
		ss=Q.front();
		Q.pop();
		if(ss.x==ed.x&&ss.y==ed.y) if(step[ss.x][ss.y]<maxt) maxt=step[ss.x][ss.y];
		for(int i=0;i<4;i++)
		{
			tt.x=ss.x+dir[i][0];
			tt.y=ss.y+dir[i][1];
			step[tt.x][tt.y]=step[ss.x][ss.y]+1;
			int d=step[tt.x][tt.y]%k;
			if(judge(tt)&&!visit[tt.x][tt.y][d])
			{
				if(map[tt.x][tt.y]=='#'&&d)
				{
						visit[tt.x][tt.y][d]=true;continue;
				}
				visit[tt.x][tt.y][d]=true;
				Q.push(tt);
			}
		}
	}

}

int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='Y')st.x=i,st.y=j;
				if(map[i][j]=='G')ed.x=i,ed.y=j;
			}
		}
		Init();
		BFS();
		if(maxt!=INF) printf("%d\n",maxt);
		else puts("Please give me another chance!");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值