HDU 1023 Traning Problem (2) 大数卡特兰数

Train Problem II
Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway. 
 

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file. 
 

Output

For each test case, you should output how many ways that all the trains can get out of the railway. 
 

Sample Input

1 2 3 10
 

Sample Output

1 2 5 16796

Hint

 The result will be very large, so you may not process it by 32-bit integers. 
         
 

Source

 

用java做就很好做了 套公式就可以了

import java.io.*;  
import java.util.*;  
import java.math.BigInteger;  
  
  
public class Main  
{  
    public static void main(String args[])  
    {         
        BigInteger[] a = new BigInteger[101];  
        a[0] = BigInteger.ZERO;  
        a[1] = BigInteger.valueOf(1);  
        for(int i = 2; i <= 100; ++i)  
            a[i] = a[i - 1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i+1));  
            Scanner in = new Scanner(System.in);  
            int n;  
            while(in.hasNext())  
            {  
                n = in.nextInt();  
                System.out.println(a[n]);  
            }  
    }  
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值