HDU 3835 R(N)

R(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2761    Accepted Submission(s): 1420


Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
 

 

Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).
 

 

Output
For each N, print R(N) in one line.
 

 

Sample Input
2 6 10 25 65
 

 

Sample Output
4 0 8 12 16
Hint
For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
 

 

Source
 

 

Recommend
xubiao
暴力题,注意不要超时就行了,注意sqrt的数一定得是int类型的。
include <iostream>
#include <math.h>
#include <stdio.h>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            cout<<1<<endl;
            continue;
        }
        int c=sqrt(n/2);
        int ans=0;
        int i,j;
        for(i=0;i<=c;i++)
        {
            j=sqrt(n-i*i);
            if(i*i+j*j==n)
            {
                if(i==0||j==0||i==j)
                ans=ans+4;
                else
                ans=ans+8;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值