poj1852蚂蚁题。

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17376 Accepted: 7407

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19


 
 
   
   
输入输出真的很重要!!!
错了好多次,终于AC了!!!
//简要的分析一下题意思想:蚂蚁相遇,可以看做交错而过。
//转化为一只蚂蚁的问题,在综合多只求最大最小就好了!

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>

using namespace std ;

const int maxn = 1000010 ;
int n , L , x [ maxn ];
void slove ()
{
int Tmin = 0 ;
for ( int i = 0 ; i < n ; i ++ ){
Tmin = max ( Tmin , min ( x [ i ], L - x [ i ])); //这里一定要转过弯来,耗时最长的最小时间作为最后的输出。
}
int Tmax = 0 ;
for ( int i = 0 ; i < n ; i ++ ){
Tmax = max ( Tmax , max ( x [ i ], L - x [ i ]));
} //这里居然错了,居然和L比长短真是ZZ!!1
printf ( "%d %d/n" , Tmin , Tmax ); //注意输出格式

}
int main ()
{

int kase ;
scanf ( "%d/n" , & kase );
while ( kase -- )
{
scanf ( "%d %d" , & L , & n ); //这里注意输入,,这里你改成逗号试试,按照原题输入,直接错!!
for ( int i = 0 ; i < n ; i ++ ) scanf ( "%d" , & x [ i ]);

slove ();

}
return 0 ;
}
//这个题的输入真的很蛋疼,一开始以为回车符不能乱加,现在知道了输入是空格对应的函数就是空格,!!



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值