poj2386结题报告

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds ave formed in his field. A pond is a connected set of squares with water in them, where a square isconsidered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output

3

Hint

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left,and one along the right side.



 
 
//这道题改了无数遍结果一直输出零,由于题目输入较长,我们可以取一个3乘3测试,技巧啊!!
//这还是一道简单题。略微有坑点。。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<stdlib.h>

using namespace std ;

int N , M ;
char filed [ 102 ][ 102 ];

void dfs ( int x , int y ) //DFS的精髓
{
filed [ x ][ y ] = '.' ; //替换现在位置
for ( int dx =- 1 ; dx <= 1 ; dx ++ ){
for ( int dy =- 1 ; dy <= 1 ; dy ++ ){

int nx = x + dx ;
int ny = y + dy ;
if ( 0 <= nx && nx <= N && 0 <= ny && ny <= M && filed [ nx ][ ny ] == 'W' ) dfs ( nx , ny );
}
}
}

int main ()
{
scanf ( "%d %d" , & N , & M );
getchar ();
for ( int i = 0 ; i < N ; i ++ ){
for ( int j = 0 ; j < M ; j ++ ){
scanf ( "%c" , & filed [ i ][ j ]); //我这里的输入形式有问题‘
}
getchar (); //加不加都可以,加上总没错吧!!
}
int count = 0 ;
for ( int i = 0 ; i < N ; i ++ ){
for ( int j = 0 ; j < M ; j ++ ){
if ( filed [ i ][ j ] == 'W' )
{ dfs ( i , j );
count ++ ;}
}
}
printf ( "%d/n" , count );

return 0 ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值