Jury Compromise

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.
Input
The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.
Output
For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.
Sample Input
4 2 
1 2 
2 3 
4 1 
6 2 
0 0 
Sample Output
Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 
Hint
If your solution is based on an inefficient algorithm, it may not execute in the allotted time.
描述
在遥远的国家佛罗布尼亚,嫌犯是否有罪,须由陪审团决定。陪审团是由法官从公众中挑选的。先随机挑选n个人作为陪审团的候选人,然后再从这n个人中选m人组成陪审团。选m人的办法是:

控方和辩方会根据对候选人的喜欢程度,给所有候选人打分,分值从0到20。为了公平起见,法官选出陪审团的原则是:选出的m个人,必须满足辩方总分和控方总分的差的绝对值最小。如果有多种选择方案的辩方总分和控方总分的之差的绝对值相同,那么选辩控双方总分之和最大的方案即可。
输入
输入包含多组数据。每组数据的第一行是两个整数n和m,n是候选人数目,m是陪审团人数。注意,1<=n<=200, 1<=m<=20 而且 m<=n。接下来的n行,每行表示一个候选人的信息,它包含2个整数,先后是控方和辩方对该候选人的打分。候选人按出现的先后从1开始编号。两组有效数据之间以空行分隔。最后一组数据n=m=0
输出
对每组数据,先输出一行,表示答案所属的组号,如 'Jury #1', 'Jury #2', 等。接下来的一行要象例子那样输出陪审团的控方总分和辩方总分。再下来一行要以升序输出陪审团里每个成员的编号,两个成员编号之间用空格分隔。每组输出数据须以一个空行结束。
方法转自kuangbin的博客:


在遥远的国家佛罗布尼亚,嫌犯是否有罪,须由陪审团决定。陪审团是
由法官从公众中挑选的。先随机挑选n 个人作为陪审团的候选人,然后
再从这n 个人中选m 人组成陪审团。选m 人的办法是:控方和辩方会
根据对候选人的喜欢程度,给所有候选人打分,分值从0 到20。为了
公平起见,法官选出陪审团的原则是:选出的m 个人,必须满足辩方
总分和控方总分的差的绝对值最小。如果有多种选择方案的辩方总分
和控方总分的之差的绝对值相同,那么选辩控双方总分之和最大的
方案即可。最终选出的方案称为陪审团方案。
为叙述问题方便,现将任一选择方案中,辩方总分和控方总分
之差简称为“辩控差”,辩方总分和控方总分之和称为“辩控和”。
第i 个候选人的辩方总分和控方总分之差记为V(i),辩方总分和控
方总分之和记为S(i)。现用f(j, k)表示,取j 个候选人,使其辩
控差为k 的所有方案中,辩控和最大的那个方案(该方案称为“方
案f(j, k)”)的辩控和。并且,我们还规定,如果没法选j 个人,
使其辩控差为k,那么f(j, k)的值就为-1,也称方案f(j, k)不可行。
本题是要求选出m 个人,那么,如果对k 的所有可能的取值,求
出了所有的f(m, k) (-20×m≤ k ≤ 20×m),那么陪审团方案
自然就很容易找到了。
问题的关键是建立递推关系。需要从哪些已知条件出发,
才能求出f(j, k)呢?显然,方案f(j, k)是由某个可行的方案f(j-1, x)
( -20×m ≤ x ≤ 20×m)演化而来的。可行方案f(j-1, x)能演化成
方案f(j, k)的必要条件是:存在某个候选人i,i 在方案f(j-1, x)中
没有被选上,且x+V(i) = k。在所有满足该必要条件的f(j-1, x)中,
选出 f(j-1, x) + S(i) 的值最大的那个,那么方案f(j-1, x)再加上候选人i,
就演变成了方案 f(j, k)。这中间需要将一个方案都选了哪些人都记录下来。
不妨将方案f(j, k)中最后选的那个候选人的编号,记在二维数组的
元素path[j][k]中。那么方案f(j, k)的倒数第二个人选的编号,
就是path[j-1][k-V[path[j][k]]。假定最后算出了解方案的辩控差是k,
那么从path[m][k]出发,就能顺藤摸瓜一步步求出所有被选中的候选人。
初始条件,只能确定f(0, 0) = 0。由此出发,一步步自底向上递推,
就能求出所有的可行方案f(m, k)( -20×m ≤ k ≤ 20×m)。实际解题
的时候,会用一个二维数组f 来存放f(j, k)的值。而且,由于题目中辩
控差的值k 可以为负数,而程序中数租下标不能为负数,所以,在程序中
不妨将辩控差的值都加上400,以免下标为负数导致出错,即题目描述中,
如果辩控差为0,则在程序中辩控差为400。

不得不说分析状态很重要,选择状态正确,才能更好的写出状态转移方程来。当时想的是一个维数表示个数,另外一个去表示以j结尾。但是不知道怎么控制,也不知道怎么写状态转移方程,当我们发现不好控制或者说写不出转移方程的时候,可以考虑换一个状态,我感觉这个用的就很巧,一维表示选择的个数,另外表示的是p[i] - d[i],感觉真的是好巧,表示这个状态转移方程就比较好想啦。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int MAXN = 2e5+7;
const int inf = 1e9;
int n,m;
int p[MAXN],d[MAXN];
int dp[25][1000];
int path[25][1000];
int ans[MAXN];

int main()
{
    int ca = 0;
    while(~scanf("%d%d",&n,&m)&&n)
    {
        for(int i = 1 ; i <= n ; ++i)scanf("%d%d",&p[i],&d[i]);
        memset(dp,-1,sizeof dp);
        memset(path,0,sizeof path);
        int min_d = m*20;
        dp[0][min_d] = 0;
        for(int j = 0 ; j < m ; ++j)
        {
            for(int k = 0 ; k <= min_d*2 ; ++k)if(dp[j][k] >= 0)
            {
                for(int i = 1 ; i <= n ; ++i)
                {
                    if(dp[j][k] + p[i] + d[i] > dp[j+1][k+p[i]-d[i]])
                    {
                        int t1 = j , t2 = k;
                        while(t1 > 0 && path[t1][t2] != i)
                        {
                            t2 -= p[path[t1][t2]] - d[path[t1][t2]];
                            t1--;
                        }
                        if(!t1)
                        {
                            dp[j+1][k+p[i]-d[i]] = dp[j][k] + p[i] + d[i];
                            path[j+1][k+p[i]-d[i]] = i;
                        }
                    }
                }
            }
        }
        int j = 0,k;
        while(dp[m][min_d + j] < 0 && dp[m][min_d - j] < 0)j++;
        if(dp[m][min_d + j] > dp[m][min_d - j])k = min_d + j;
        else k = min_d - j;
        printf("Jury #%d\n",++ca);
        printf("Best jury has value %d for prosecution and value %d for defence:\n",(k-min_d+dp[m][k])/2,(dp[m][k]-k+min_d)/2);
        j = m;
        int cnt = 0;
        while(j > 0)
        {
            ans[cnt++] = path[j][k];
            k -= p[path[j][k]] - d[path[j][k]];
            j--;
        }
        sort(ans,ans+cnt);
        for(int i = 0 ; i < cnt ; ++i)printf(" %d",ans[i]);
        puts("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值