1099 Build A Binary Search Tree (30分)

23 篇文章 0 订阅

1 题目

1099 Build A Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.figBST.jpg
在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

      
    
Sample Output:
58 25 82 11 38 67 45 73 42

2 解析

2.1 题意

给定BST的形状以及输入序列,求BST的层序遍历序列

2.2 思路

  • 1 首先根据给定的树形,构造出二叉树(由于题目直接给了结点编号,所以使用二叉树的静态写法)【由于根结点默认为编号0,因此不需要寻找根结点】
  • 2 中序遍历二叉树,访问根结点时填入排序后的输入序列,从而来给结点的数据赋值
  • 3 层序遍历构造完的二叉树,输出层序遍历序列

3 参考代码

#include <cstdio>
#include <algorithm>
#include <queue>
using std::sort;
using std::queue;

const int MAXN = 110;
int N;
int Seq[MAXN], res[MAXN];
int Count = 0;

struct node
{
    int lchild;
    int rchild;
    int data;
}Node[MAXN];


void inorder(int root){//中序遍历
    if(root == -1) return;

    inorder(Node[root].lchild);
    Node[root].data = Seq[Count++];
    inorder(Node[root].rchild);
}

void layerorder(int root){//层序遍历
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int now = q.front();
        q.pop();

        Count++;
        printf("%d", Node[now].data);
        if(Count < N) printf(" ");

        if(Node[now].lchild != -1){
            q.push(Node[now].lchild);
        }
        if(Node[now].rchild != -1){
            q.push(Node[now].rchild);
        }
    }
}

int main(int argc, char const *argv[])
{
    scanf("%d", &N);

    int left, right;
    for (int i = 0; i < N; ++i)
    {
        scanf("%d%d",&left, &right);
        Node[i].lchild = left;
        Node[i].rchild = right; 
    }

    for (int i = 0; i < N; ++i)
    {
        scanf("%d", &Seq[i]);
    }

    sort(Seq, Seq + N);//排序

    inorder(0);
    Count = 0;//重置计数Count
    layerorder(0);

    return 0;
}

/*
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值