1042 Shuffling Machine (20 分)

 

Shuffling is a procedure(程序) used to randomize a deck(甲板、层) of(一副) playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate(合作) with gamblers(赌徒-s) by performing inadequate(不充分的) shuffles, many casinos(赌场-s) employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order(顺序) and repeats for a given number of times. It is assumed that the initial(首字母/初始) status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade"(黑桃♠️), "H" for "Heart"(红桃♥️), "C" for "Club"(梅花♣️), "D" for "Diamond"(方块♦️), and "J" for "Joker"(小丑-大小鬼?). A given order is a permutation(排列) of distinct(不同的) integers(整数-s) in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification(要求):

Each input file contains(包括-s) one test case(事例). For each case, the first line contains a positive integer(正整数) K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space(空格) at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

参考代码:

//甲练 Shuffing Machine
#include<cstdio>
const int N = 54;
char mp[5]={'S','H','C','D','J'};//牌的编号和花色对应的关系
int start[N+1],next[N+1],end[N+1];//next数组用于存放操作后的位置
int main(int argc, char const *argv[])
{
	int K;
	scanf("%d",&K);

for (int i = 1; i < N+1; ++i)
{
	start[i]=i;//初始化牌的编号
}

for (int i = 1; i < N+1; ++i)
{
	scanf("%d",&next[i]);//输入每个位置牌的编号
}

while(K--){  //实行K次操作
	for (int i = 0; i < N+1 ; ++i)
	{
		end[next[i]]=start[i];//把第i个位置的编号存于位置next[i]
	}

	for (int j = 1; j <=N; ++j)
{
	start[j]=end[j];//把end数组的复制给start,以供下次使用
}

}

for (int i = 1; i <=N; ++i)
{
	if(i != 1) printf(" ");//控制输出格式
	start[i]--;
	printf("%c%d", mp[start[i]/13], start[i]%13+1);//输出结果
}

return 0;
}

参考代码2:


// 类似快速幂求法,
// 洗2次牌可以合并成1次,合并举例: 4 3 1 5 2(1先到4再到5)洗两次相当于 5 1 4 2 3洗一次.所以洗k次就可以两两合并从而大大减少洗牌次数

#include<bits/stdc++.h>
 
using namespace std;
 
  
 
vector<int> shuffling(const vector<int> &ori,const vector<int> &order){
 
    vector<int> res(55);
 
    for(int i=1;i<55;i++){
 
        res[order[i]]=ori[i];
 
    }
 
    return res;    
 
}
 
 
vector<int> merg(const vector<int> &order){
 
    vector<int> res(55);
 
  
    for(int i=1;i<55;i++){
 
        res[i]=order[order[i]];
 
    }
 
    return res;
}
 
int main(){
 
    int r;
 
    cin>>r;
 
     
    vector<int> order(55);//1~54
 
     
    for(int i=1;i<55;i++){
 
        cin>>order[i];
 
    }
 
 
    //快速幂
 
    vector<int> res(55);
 
    for(int i=1;i<55;i++){
 
        res[i]=i;
 
    }
 
     
 
    while(r){
 
        if(r%2==0){
 
            order=merg(order);
 
            r/=2;
 
        }else{
 
             
 
            res=shuffling(res,order);
 
            r--;
 
        }
 
    }
 
     
 
    //输出
 
    for(int i=1;i<55;i++){
 
        int cas=(res[i]-1)/13;
 
        int num=res[i]-cas*13;
 
         
 
        switch(cas){
 
            case 0:
 
                cout<<"S";
 
                break;
 
            case 1:
 
                cout<<"H";
 
                break;
 
            case 2:
 
                cout<<"C";
 
                break;
 
            case 3:
 
                cout<<"D";
 
                break;
 
            case 4:
 
                cout<<"J";
 
                break;
 
        }
 
         
 
        cout<<num;
 
        if(i!=54)cout<<" ";
 
    }
 
     
 
    return 0;
 
}

 

推荐代码:

#include <cstdio>
using namespace std;
 
int main() {
    int cnt;
    scanf("%d", &cnt);
    int start[55], end[55], scan[55];
    for(int i = 1; i < 55; i++) {
        scanf("%d", &scan[i]);
        end[i] = i;
    }
    for(int i = 0; i < cnt; i++) {
        for(int j = 1; j < 55; j++) {
            start[j] = end[j];
        }
        for(int k = 1; k < 55; k++) {
            end[scan[k]] = start[k];
        }
    }
    char c[6] = {"SHCDJ"};
    for(int i = 1; i < 55; i++) {
        end[i] = end[i] - 1;
        printf("%c%d", c[end[i] / 13], end[i] % 13 + 1);
        if(i != 54) printf(" ");
    }
    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值