1050 String Subtraction(减法) (20 分)

23 篇文章 0 订阅
10 篇文章 0 订阅

 

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

参考代码:

#include<cstdio>
#include<cstring>
const int maxn = 10010;
char str1[maxn], str2[maxn];
bool hashtable[128] ={false};//记录字符是否在第二个字符串里出现

int main(int argc, char const *argv[])
{
  fgets(str1, maxn + 1, stdin);
  fgets(str2, maxn + 1, stdin);
  int len1 = strlen(str1) - 1;
  int len2 = strlen(str2) - 1;

for (int i = 0; i < len2; ++i)
{
  hashtable[str2[i]] = true;//第二个字符串里的字符的table位置true
}

for (int i = 0; i < len1; ++i)
{
  if(hashtable[str1[i]] == false) printf("%c", str1[i]);//如果在第二个字符串中俄密友出现过
}

printf("\n");
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值