1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons(优惠卷). Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus(红利、奖金) product, you will have to pay the shop Ntimes the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

参考代码:

#include<cstdio>
#include<algorithm>

using namespace std;

const int maxn = 2000000000;
double coupons[maxn];
double pd[100010];
long long res = 0;


int main(){
    int NC, NP;
    scanf("%d", &NC);
    for (int i = 0; i < NC; ++i) {
        scanf("%lf", &coupons[i]);
    }
    scanf("%d", &NP);
    for (int j = 0; j < NP; ++j) {
        scanf("%lf", &pd[j]);
    }
    sort(coupons, coupons + NC);
    sort(pd, pd + NP);

    int i = 0;
    while(i < NC && i < NP && coupons[i] < 0 && pd[i] < 0){
        res += coupons[i] * pd[i];
        i++;
    }
    i = NC - 1;
    int j = NP - 1;
    while(i >= 0 && j >= 0 && coupons[i] > 0 && pd[j] > 0){
        res += coupons[i] * pd[j];
        i--;
        j--;
    }
    printf("%lld\n", res);
    return 0;


}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值