1037 Magic Coupon (25 分)

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

tips

提交次数通过样例tips
13/6未考虑全面(见下红色字体)
25/6段错误:105是100000(5个零
3all
  • 思路:对于正数:大的数与大的数相乘再相加结果最大;对于负数:小的数与小的数相乘再相加结果肯定最大(即绝对值大的数和绝对值大的数相乘)
  • 因此,先对两个数组均由大到小排列,前面的所有正数对应相乘再相加;当遇到两数相乘为负数停止;当两个数均为负数时也停止(这种情况对应于两个数组中均只有负数的情况,为了避免与后面的计算重复)
由大到小排序
例1
4 2 1 -1
7 6 -2 -3
选择前面的正数相乘相加:4*7 + 2*6 = 402
-1 -2 -3 -4
-3 -4 -5 -7
这种情况直接停止,防止与后面的计算重复

例3
4 3 2 1
7 5 3 2
选择4*7 + 3*5 + 2*3 + 1*2
  • 再对两个数组由小到大排序,对所有负数相乘相加,当遇到两数相乘为负数时停止;当两个数均为正数时也要停止(这种情况对应于两个数组中的数均为正数的情况,避免与上重复计算)
由小到大排序
例1
-1 1 2 4
-3 -2 6 7
选择(-1)*(-3) = 32
-4 -3 -2 -1
-7 -5 -4 -3
选择(-4)*(-7) + (-3)*(-5) + (-2)*(-4) + (-1)*(-3)3
1 2 3 4
7 5 3 2
直接停止,避免与上重复计算

code

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

const int maxn = 100100;
int coupons[maxn];
int values[maxn];

bool cmp(const int a, const int b)
{
    return a > b;
}

int main()
{
    int c,p;
    long long ans = 0;
    scanf("%d",&c);
    for(int i = 0; i < c; i++){
        scanf("%d",&coupons[i]);
    }
    scanf("%d",&p);
    for(int i = 0; i < p; i++){
        scanf("%d",&values[i]);
    }
    sort(coupons, coupons + c); //从小到排
    sort(values, values + p);
    for(int i = 0; i < c && i < p; i++){
        if(coupons[i] * values[i] < 0) break;
        if(coupons[i] > 0 && values[i] > 0) break;
        ans += coupons[i] * values[i];
    }
    sort(coupons, coupons + c, cmp);//从大到小排
    sort(values, values + p, cmp);
    for(int i = 0; i < c && i < p; i++){
        if(coupons[i] * values[i] < 0) break;
        if(coupons[i] < 0 && coupons[i] < 0) break;
        ans += coupons[i] * values[i];
    }
    printf("%lld",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值