SDAU 课程练习 1016

Problem Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

 

Input

* Line 1: A single integer N< br>< br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

 

Output

* Line 1: A single integer that is the median milk output.

 

Sample Input

5

2

4

1

3

5

 

Sample Output

3

题目大意:

输入N 组数据 找出平均值。

思路:

可以直接输入后sort排序  输出中间下标,也可以直接建立一个multiset容器  因为set自动排序嘛。

感想:

按照费老师的话来说,这个算是签到题 嘿嘿。

AC代码:​​​​​

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
using namespace std;
int main()
{
    int N,t;
    //freopen("r.txt", "r", stdin);
    multiset<int> s;
    multiset<int> ::iterator it;
    while(cin>>N)
    {

        for(int i=1;i<=N;i++)
        {
            scanf("%d",&t);
            s.insert(t);
        }
        it=s.begin();
        for(int i=1;i<=N/2;i++)
            it++;
        cout<<(*it)<<endl;


    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值