acm 1016 牛奶中位数

1.1016

2.

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N <br> <br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5
2
4
1
3


Sample Output

3.输入牛奶的产量,算出中位数,使用动态数组放置产量,使用stl中的sort函数进行数组排序,注意单双数问题

4.题目与实际实例相结合,读起来有一定的困难和迷惑性,但其实就是一个中位数问题,认真看题,明白题意后就没有多少困难,注意动态数组的使用*-*

5.

#include<iostream>

#include<vector>

#include<algorithm>

using namespacestd;

int main()

{   int n,i,j,m;

    vector<int> a;

     while(cin>>n)

    { for(i=0;i<n;i++)

        {  cin>>j;

          a.push_back(j);

        }

        sort(a.begin(),a.end());

        if(n%2==0)

           {m=(a[n/2]+a[(n/2)-1])/2;}

        else

           {m=a[(n-1)/2];}

        cout<<m<<endl;

    }

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值