HDU 2642 Stars 二维树状数组

Stars

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 105 Accepted Submission(s): 49
 
Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 
Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 
Output
For each query,output the number of bright stars in one line.
 
Sample Input
5
B 581 145
B 581 145
Q 0 600 0 200
D 581 145
Q 0 600 0 200
 
Sample Output
1
0
 
Author
teddy
 
Source
题目大意:

B 为点亮  x  y  这个星星  ,一开始星星是  暗的,  D 是熄灭这个星星,Q  是查询这个区间内多少个亮着的星星。
注意  q   后面给出的  数据   x1   x2   y1   y2  

思路:

裸二维树状数组。

AC代码:

#include<bits/stdc++.h>
using namespace std;
#define N 1005
int C[N][N];
bool falg[N][N];
int sum(int x,int y)
{
    int ret=0,i,j;
    for(i=x; i>0; i-=(i&-i))
        for(j=y; j>0; j-=(j&-j))
            ret+=C[i][j];
    return ret;
}
void add(int x,int y,int d)
{
    int i,j;
    for(i=x; i<N; i+=(i&-i))
        for(j=y; j<N; j+=(j&-j))
            C[i][j]+=d;
}
int main()
{
    int t,n,a,b,c,d,e,i,j,k,v;
    char s[5];
    while(~scanf("%d",&n))
    {
        for(i=1; i<N; ++i)
            for(j=1; j<N; ++j)
            {
                C[i][j]=0;
                falg[i][j]=0;
            }
        while(n--)
        {
            scanf("%s",s);
            if(s[0]=='Q')
            {
                scanf("%d%d%d%d",&a,&c,&b,&d);
                if(a<c) swap(a,c);
                if(b<d) swap(b,d);
                printf("%d\n",sum(a+1,b+1)-sum(a+1,d)-sum(c,b+1)+sum(c,d));
            }
            else if(s[0]=='B')
            {
                scanf("%d%d",&a,&b);
                if(falg[a+1][b+1])
                    continue;
                add(a+1,b+1,1);
                falg[a+1][b+1]=1;
            }
            else if(s[0]=='D')
            {
                scanf("%d%d",&a,&b);
                if(falg[a+1][b+1]==0)
                    continue;
                add(a+1,b+1,-1);
                falg[a+1][b+1]=0;
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值