01背包(转换思想)(背包容量超大~)

C - Knapsack problem
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

15 1512 42 21 14 101 2

Sample Output

15

FAQ | About Virtual Judge | Forum | Discuss | Open Source Projec

题意 : 01背包的典型例题,题意就不BB了,此题背包容量过大,内存会超~~

思路: 根据01背包的思想,满足在背包容量以内,用最小的容量,装价值最大的物品。但是此题 背包容量过大,而价值之和的最大值只有5000,我们可以转换思路,利用01背包的思想,用最大价值来求最小容量;即为,把价值之和看作是背包的容量,进行背包。


代码:

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<map>
#define max(a,b)(a>b?a:b)
#define min(a,b)(a<b?a:b)
typedef long long ll;
using namespace std;
#define N 5100
ll dp[N],w[N];  ///此时的dp[i]表示的是;价值为i时的最小容量为dp[i];
int v[N];

int main()
{
    int T,i,n,sum;
    ll V;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%I64d",&n,&V);
        sum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%I64d%d",&w[i],&v[i]);
            sum=sum+v[i];
        }

        memset(dp,1000000010,sizeof(dp)); ///要求最小容量,初始化为最大值;
        dp[0]=0;
        for(i=1;i<=n;i++)
        {
            for(int j=sum;j>=v[i];j--)
                dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
        }

        for(i=sum;i>=0;i--)
        {
            if(dp[i]<=V)
            {
               printf("%d\n",i); ///此处输出i,即为满足条件的最大价值
               break;
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值