HDU 1017 A Mathematical Curiosity

题目:

输入数据N ,代表N组多实例;

输入n,m代表两个数,且 a<b<n(n<100)

如果有a,b,使(a^2+b^2 +m)/(ab)为整数,(既互相取余为0)

则(a,b)为一组数;问输入的数据中,有多少组这样的数据(a,b);

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input

    
    
1 10 1 20 3 30 4 0 0
 

Sample Output

    
    
Case 1: 2 Case 2: 4 Case 3: 5


想明白后是个超级大水题,但是由于手残,让b==n的情况出现了,结果就错了;

这里有个小技巧,因为b>a。故有,b=a+1;

因为a b 都小于n ,则有 a<n-1 , b<n;

这样搜索效率比直接卡100边界快得多了;

还有就是不要忘了初始化每一次实例满足组数的个数,都得从1开始;

#include <bits/stdc++.h>
using namespace std ;
int main()
{
	int a , b ,n , m; 
	int t ,k;
	int sum;
	cin>>t;
	
	while(t--)
	{
		k=1;
		while(cin>>n>>m,n+m)
		{
			sum=0;
			for(int a = 1 ; a<n-1;a++)
			{
				for(int b =a+1 ; b<n;b++)
				{
					if((a*a+b*b+m)%(a*b)==0)
					{
						sum++;
					}
				}
			}
			printf("Case %d: %d\n",k++,sum);
		}
		if(t!=0)
		printf("\n");
	}
	return 0 ;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值