【简单DP】 数字三角形

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

<span style="font-size:12px;">7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5</span>

Sample Output

30


从现在开始,做个DP大神;

DP的初级思路就是推规律,找状态,就本题而言,只有两种选择,直下,或者斜下;

若i代表行,j代表列, 当前位置为(i,j) , 那么下一种状态就是(i+1,j)或者(i+1,j+1);

换言之上一种状态就是(i-1,j)或者(i-1, j-1) ; 因为不确定要究竟走到哪但是却知道行数;

所以只需要找到第n行枚举所有到达(n,j) (1<= j <= n ) 的最大值就行;

可以得到四种状态

dp[1][1] = map[1][1] ;(第一行只有一个值)

dp[i][1]=dp[i-1][1]+map[i][1] ; (第一列的值只能拿(1,1)推过来因为只能垂直向下走);

dp[i][i] =dp[i-1][i-1] +map[i][i] ; (最右边的斜边都是从(1,1)推到(n,n);斜着走);

dp[i][j] =max(dp[i-1][j] , dp[i-1][j-1])+map[i][j] ;(正常情况的状态方程,选择当前最大值);


AC代码:

<span style="font-size:12px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
int dp[500][500] , ma[500][500];
int main()
{
	int n ;
	while(cin>>n)
	{
		memset(dp,0,sizeof(dp));
		memset(ma,0,sizeof(ma));
		
		for(int i = 1 ; i<=n ; i++)
		{
			for(int j = 1 ;j<=i ; j++)
			{
				  cin>>ma[i][j];
			}
		}
		for(int i = 1 ; i<= n ;i++)
		{
			for(int j = 1; j<=i;j++)
			{
				if(i==1) dp[i][j] = ma[i][j];
				else if(j==1) dp[i][j] = dp[i-1][j] + ma[i][j];
				else if(j==i) dp[i][j] = dp[i-1][j-1] + ma[i][j];
				else dp[i][j] = max(dp[i-1][j],dp[i-1][j-1])+ma[i][j];
			}
		}
		int ans = 0 ;
		for(int i =1 ;i<=n; i++)
		{
			if(dp[n][i]>ans)
			{
				ans = dp[n][i];
			}
		}
		cout << ans <<endl;
	}
	return 0 ;
}</span>





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值