【01背包】Charm Bracelet

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver


01背包的状态:0 和 1 ; (选择/不选择) ; 

本题求的是不超过最大限度的重量要求最大的价值;

用 F[i][j] 表示取前i 种物品,使它们总体积不超过j的
最优取法取得的价值总和
递推: F[i][j] = max(F[i -1][j],F[i -1][j-w[i]]+d[i])
取或不取第 i 种物品,两者选优
(j-w[i] >= 0才有第二项)



AC代码:

#include<iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ; 
struct node {
	int val ;
	int wei ;
}a[50000];
int n , m ;
int dp[60000];
int main()
{
	while(cin>>n>>m)
	{
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		for(int i = 1 ; i<= n ; i++)
		{
			cin>>a[i].wei>>a[i].val;
		}
		for(int i = 1 ; i<= n ; i++)
		{
			for(int j = m ;j>=a[i].wei ;j--)
			{
				if(dp[j]<dp[j-a[i].wei]+a[i].val)
				{
					dp[j]=dp[j-a[i].wei]+a[i].val;
				}
			}
		}
		cout<<dp[m]<<endl;
	}
	return 0 ;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值