【经典DP类型】 最大连续子序列和

Description

HenryFour has a number of stones which have different values from -4444 to 4444. He puts N stones in a line and wants to find the max partial value of these N stones. 

Assume the values of the N stones in line are: v1, v2, v3, v4, ..., vN. The partial vaule of stones from Lth stone to Rth stone (1 ≤ L ≤ R ≤ N) is the sum of all the stones between them. i.e. PartialV(L, R) = v[L] + v[L+1] + .... + v[R] (1 ≤ L ≤ R ≤ N) 

Since the number of stones (N) is very very large, it is quite difficult for HenryFour to find the max partial value. So could you develop a programme to find out the answer for him? 
 

Input

There are several test cases in the input data. The first line contains a positive integer T (1 ≤ T ≤ 14), specifying the number ot test cases. Then there are T lines. Each of these T lines contains a positive number N followed by N integers which indicate the values of the N stones in line. 
1 ≤ N ≤ 1,000,000 
-4444 ≤ v[i] ≤ 4444 
 

Output

Your program is to write to standard output. For each test case, print one line with three numbers seperated by one blank: P L R. P is the max partial value of the N stones in line. L and R indicate the position of the partial stones. If there are several Ls and Rs that have the same value PartialV(Li, Ri) = P, please output the minimum pair. For pair (Li, Ri) and (Lj, Rj), we define (Li, Ri) < (Lj, Rj) if and only if: Li < Lj or (Li == Lj and Ri < Rj) 
 

Sample Input

    
    
3 4 32 -39 -30 -28 8 1 2 3 -10 1 -1 5 1 10 14 -12 -8 -13 3 5 42 -24 -32 -12
 

Sample Output

    
    
32 1 1 6 1 3 50 5 7

Hint

 Huge input and output,scanf and printf are recommended. 

大致题意:找出子串中和最大的,并且标注区间, 套路题;

AC代码:

#include <iostream>
using namespace std;

int main()
{
    int n,m,i,l ,r ,y;
    long long max,p1,p2,now,temp;
    cin>>n;
    while(n--)
    {
        cin>>m>>temp;
        now=max=temp;
        r=l=p1=p2=1;
        for(i=2; i<=m; i++)
        {
            cin>>temp;
            if(temp>now+temp)
            {
                now=temp;
                p1=i;
            }
            else
            {
                now+=temp;
            }
            if(now>max)
            {
                l=p1;
                r=i;
                max=now;
            }

        }
        cout<<max<<" "<<l<<" "<<r<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值