POJ 2236 Wireless Network

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


题目大意:有一堆电脑互相连着是可以上网的,电脑间相连接是可以通信的; 现在给出n台电脑的坐标, 和最大距离d , 如果两台相互连接的电脑直接的距离大于d则不能愉快     的进行通信;其中O代表的是对第n台电脑进行维修, S a b 是 对 a b 两个电脑进行连接;

AC代码:

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
int f[1010],x[1010],y[1010];
int d,n,i,r,r1,k1,k2;
bool v[1010];
char ch;
int find(int i) {
    if (i!=f[i]) f[i]=find(f[i]);
    return f[i];
}
bool dis(int a, int b) {
     int q=x[a]-x[b];
     int w=y[a]-y[b];
     if (q*q+w*w<=d*d) return true;
     else return false;
}
int main() {
    cin >> n >> d;
    for (i=1;i<=n;i++) {
        f[i]=i;
        v[i]=false;
    }
    for (i=1;i<=n;i++) 
        scanf("%d%d",&x[i],&y[i]);
    while (cin >> ch) {
          if (ch=='O') {
                       scanf("%d",&r);
                       v[r]=true;
                       for (i=1;i<=n;i++)
                           if (i!=r && v[i] && dis(i,r)) {
                                    k1=find(r);
                                    k2=find(i);
                                    f[k1]=k2;
                           }
          }
          if (ch=='S') {
                       scanf("%d%d",&r,&r1);
                       k1=find(r);
                       k2=find(r1);
                       if (k1==k2) cout << "SUCCESS" << endl;
                       else cout << "FAIL" << endl;
          }
    }
    return 0;
}
                       

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值