HDU 5651 xiaoxin juju needs help [组合数]

Description

As we all known, xiaoxin is a brilliant coder. He knew **palindromic** strings when he was only a six grade student at elementry school. 

This summer he was working at Tencent as an intern. One day his leader came to ask xiaoxin for help. His leader gave him a string and he wanted xiaoxin to generate palindromic strings for him. Once xiaoxin generates a different palindromic string, his leader will give him a watermelon candy. The problem is how many candies xiaoxin's leader needs to buy? 

Input

This problem has multi test cases. First line contains a single integer   which represents the number of test cases. 
For each test case, there is a single line containing a string 

Output

For each test case, print an integer which is the number of watermelon candies xiaoxin's leader needs to buy after mod  .

Sample Input

3
aa
aabb
a

Sample Output

1
2
1


题目大意:给你一串字符串,问你任意换可以组成回文串的个数, 先递推所有组合数,并且注意判断一下特殊就行

AC代码:

#include <bits/stdc++.h>
#define mod 1000000007
#define ll long long
using namespace std ;
int c[550][550] ;
void init()
{
    int i , j ;
    for(i=0; i<=500; i++)
        c[i][0]=1;
    for(i=1; i<=500; i++)
        for(j=1; j<=i; j++)
            c[i][j]=c[i-1][j]+c[i-1][j-1],c[i][j]%=mod;
}
int main()
{
    init();
    char s[1000] ;
    int a[26] ;
    int t ;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        cin>>s;
        int len = strlen(s);
        for(int i = 0 ; i < len ; i++)
        {
            int x = s[i] - 'a';
            a[x]++;
        }
        int cnt = 0 ;
        for(int i = 0 ; i < 26;i++)
        {
            if(a[i]%2==1) cnt++;
            a[i]/=2;
        }
        if(cnt>1||(cnt==1&&len%2==0))
        {
            printf("0\n");
            continue;
        }
        len/=2;
        ll ans = 1;
        for(int i = 0 ; i <26 ; i++)
        {
            if(a[i])
            {
                ans*=c[len][a[i]];
                len-=a[i];
                ans = ans %mod ;
            }
        }
        cout<<ans<<endl;
    }
}

1

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值