hdu1498——最小点覆盖

hdu1498  50 years, 50 colors:http://acm.hdu.edu.cn/showproblem.php?pid=1498

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2005    Accepted Submission(s): 1104


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
  
  
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
  
  
-1 1 2 1 2 3 4 5 -1
题意:给出一个n*n的矩阵,每一次你可以任选一行或一列,将里面的相同的气球戳破,,问k次后有哪些气球不能戳完(还有剩余)。。。。。

思路:完全没思路啊,跟以前的最小点覆盖有点不一样(菜鸟渣渣),于是看了看诸位大神写的。。。。。好好想想还是可以想通的:分别对每种颜色的气球进行匹配,若匹配出来的结果大于k次,那么说明这种气球不能在k次内完成。。。。就这样对每种颜色的气球都进行匹配。。其实这就相当于行对列进行匹配(列对行)。。。瞬间觉得叼叼的,也真的是涨姿势了!(Too young……

Ac代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<string>
#include<stack>
#include <map>
#include <set>
using namespace std;

const int maxn=500 + 10;
int n,m;
int g[maxn][maxn];
set<int>Set;
int vis[maxn],link[maxn];

bool path(int u,int x)
{
    for(int i = 0; i < n; i++)
        if(g[u][i] == x && !vis[i])    // 跟以前的最小点覆盖的写法不一样的地方,将等于1换成等于当前颜色的气球。
        {
            vis[i] = 1;
            if(link[i] == -1 || path(link[i],x))
            {
                link[i] = u;
                return true;
            }
        }
    return false;
}
int dfs(int x)
{
    memset(link,-1,sizeof(link));
    int ans = 0;
    for(int i = 0; i < n; i++)
    {
        memset(vis,0,sizeof(vis));
        if(path(i,x))ans++;
    }
    return ans;
}
int main()
{
//    freopen("in.txt","r",stdin);
    int t;
    while(~scanf("%d%d",&n,&m) && (n || m))
    {
        Set.clear();
        memset(g,0,sizeof(g));
        for(int i = 0; i < n; i ++)
            for(int j = 0; j < n; j++)
            {
                scanf("%d",&g[i][j]);
                Set.insert(g[i][j]);
            }
        set<int>::iterator it;
        int falg = 1,findl = 1;
        for(it = Set.begin(); it != Set.end(); it++)
        {
            if(dfs(*it) > m)
            {
                findl = 0;
                if(falg)printf("%d",*it),falg = 0;
                else printf(" %d",*it);
            }
        }
        if(findl)printf("-1");
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值