Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Key Next
where Address
is the position of the node, Key
is an integer of which absolute value is no more than 104, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
Ω
对一个链表进行绝对值去重,即将绝对值与前面节点重复的节点单独取出组成一个新的链表,最后输出两个链表。
首先读入所有节点,然后用一个map<int,bool>
记录出现过的节点key,再用两个vector<string,int>
来模拟链表,最后直接按顺序输出即可。
🐎
#include <iostream>
#include <map>
#include <vector>
using namespace std;
int main()
{
int n, m;
string head, crt, nxt;
cin >> head >> n;
map<string, pair<int, string>> node;
for (int i = 0; i < n; ++i)
{
cin >> crt >> m >> nxt;
node[crt] = make_pair(m, nxt);
}
map<int, bool> flag;
crt = head;
vector<pair<string, int>> stay, rmv;
while (crt != "-1")
{
if (flag[abs(node[crt].first)])
rmv.emplace_back(crt, node[crt].first);
else
{
stay.emplace_back(crt, node[crt].first);
flag[abs(node[crt].first)] = true;
}
crt = node[crt].second;
}
stay.emplace_back("-1", 0), rmv.emplace_back("-1", 0);
for (int i = 0; i < stay.size() - 1; ++i)
printf("%s %d %s\n", stay[i].first.c_str(), stay[i].second, stay[i + 1].first.c_str());
for (int i = 0; i < rmv.size() - 1; ++i)
printf("%s %d %s\n", rmv[i].first.c_str(), rmv[i].second, rmv[i + 1].first.c_str());
}