A1064 Complete Binary Search Tree (30 分)(构建完全二叉排序树)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意:

 给出N个非负整数,要用他们构建一个完全二叉排序树,输出这颗完全二叉树的层次遍历序列

思路:

本题难点:构建完全二叉排序树,完美利用完全二叉排序树的性质即可解

完全二叉树:结点x 的左孩子为 2*x, 右孩子为 2*x+1,开一个数组,存储该完全二叉树的节点,注意根节点从 1 开始

二叉排序树:中序遍历递增,对于输入的数字,从小到大排序,对以上的数组,进行中序遍历,同时从小到大存入数字。

层次遍历:数组本就是按照二叉树层序来存放结点的,因此按照顺序输出即为层次遍历的顺序

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1010;
//number存储节点的权值,CBT存放完全二叉树,index从小到大枚举number数组
//n为结点数
int n, number[maxn], CBT[maxn], index = 0;
void inOrder(int root){
    if(root > n)      //CBT[1] ~ CBT[n]存放n个结点
        return;
    inOrder(root * 2);  //往左子树递归
    CBT[root] = number[index++];    //根节点处赋值
    inOrder(root * 2 + 1);  //右子树递归
}
int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &number[i]);
    }
    sort(number, number + n);
    inOrder(1);     //1号位为根节点
    for(int i = 1; i <= n; i++){
        printf("%d", CBT[i]);
        if(i < n)
            printf(" ");
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值