不同的DP方程不同的效率(2845)

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3944    Accepted Submission(s): 1873


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
  
  
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
  
  
242

刚开始使用max_sum=max(max_sum,dp[i]+num[j]) (1<=i<=j-1) ,TLE两次,在这里dp[i]表示用上第i个元素的最大值,所以还要和max_sum比较。后来使用dp[j]=max(dp[j-2]+num[j],dp[j-1]) , 在这里dp[j]表示到第j个元素为止最大的不连续和。可以看出后者比前者更加紧凑,条件限制得更多,两个选择之间不应该相差太远,否则不可能是最优解,所以应当使用后者提高效率。仔细思考无后效性这个特点。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
/*---------------------Work-----------------------*/
int dp[200050];
int sum[200050];
void work()
{
	int M,N;
	while(cin>>M>>N)
	{
		int ans;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=M;i++)
		{
			for(int j=1;j<=N;j++)
			{
				scanf("%d",&ans);
				if(j>=2) dp[j]=max(dp[j-2]+ans,dp[j-1]); //未加=号,WA一次,前两个也要比较 
				else dp[j]=ans;
			}
			sum[i]=dp[N];
		}
		memset(dp,0,sizeof(dp));
		for(int j=1;j<=M;j++)
		{
			if(j>=2) dp[j]=max(dp[j-2]+sum[j],dp[j-1]);
			else dp[j]=sum[j];
		}
		printf("%d\n",dp[M]);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值