二维映射成一维(1541)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7385    Accepted Submission(s): 2915


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0

这道题目关键点在于二维的坐标系转化成一维的,其实从输入的特殊性就应该想到这一点,然后再利用树状数组的优势快速求前缀和。还有很多小细节需要处理:首先树状数组内  存的数据是x坐标,所以更新的时候要更新到x坐标的最大值32050,还有一个很难以发现的问题:x坐标可能为0!lowbit之后可能陷入一个死循环,所以刚输入x之后马上所有都+1,避免了死循环。仔细体会这个过程,不要造成思维定式。


/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 100050
/*---------------------Work-----------------------*/
int n,level[32050],tree[32050];
int lowbit(int i)
{
	return i&-i;
}
void update(int i,int num)
{
	while(i<=32050) //这里需要更改,改成坐标值上限
	{
		tree[i]+=num;
		i+=lowbit(i);
	}
}
int getsum(int i)
{
	int sum=0;
	while(i>=1)
	{
		sum+=tree[i];
		i-=lowbit(i);
	}
	return sum;
}
void work()
{
	while(scanf("%d",&n)==1)
	{
		memset(level,0,sizeof(level));
		memset(tree,0,sizeof(tree));
		int x,y,cnt;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			x++; //这一步很关键,因为x有可能是0,导致死循环
			cnt=getsum(x);
			level[cnt]++;
			update(x,1);
		}
		for(int i=0;i<=n-1;i++)
			printf("%d\n",level[i]);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值