Greedy?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2431 Accepted Submission(s): 811
Problem Description
iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.
Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.
Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.
Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000
Output
For each test case, output the case number first, then the smallest maximum penalty.
Sample Input
2 2 3 4 2 2 4 3 6 2 7 4 5 3 9
Sample Output
Case 1: 1 Case 2: 3
Author
iSea@WHU
Source
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
struct node
{
int c, d;
}ta[100050];
bool cmp(node a, node b)
{
return a.d < b.d;
}
int main()
{
int T;
scanf("%d", &T);
for(int Case = 1; Case <= T; Case++)
{
scanf("%d", &n);
for (int i = 1; i <= n; i++)
scanf("%d%d", &ta[i].c, &ta[i].d);
sort(ta + 1, ta + n + 1, cmp); // 按截止日期排序
long long sum = 0;
long long ans = 0; // 记录超时的最大值
for (int i = 1; i <= n; i++)
{
sum += ta[i].c;
ans = max(ans, sum - ta[i].d);
}
printf("Case %d: %I64d\n", Case, ans);
}
system("pause");
return 0;
}