POJ 2777 Count color

题目

Problem Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

 

Output

Ouput results of the output operation in order, each line contains a number.

 

Sample Input

2 2 4 C 1 1 2 P 1 2 C 2 2 2 P 1 2

Sample Output

2 1

 

     相比一般的区间修改问题,这道题目的一个小技巧在于使用一个int变量来保存color的种类,这样在计算两堆color的并集的时候,可以直接使用或运算得到结果,这样相比于hash表会更加快速。 另外,lazy tag无论存储为什么形式,它的根本目的只是标记这个当前这个节点还包含了子节点的修改信息。对于当前这个涂色问题,因为子节点的修改可以直接参考父节点的涂色,因此lazy tag只需要表示为0和1即可。

#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;
//using ll = long long;

const int MAXN = 1e5+10; 
struct node{
  int color; int tag; int l, r;
  node(){color = 0;tag = 0;}
};

vector<node> tree(MAXN<<2);

void pushDown(int id){
  tree[id<<1].color = tree[id<<1|1].color = tree[id].color; 
  tree[id<<1].tag = tree[id<<1|1].tag = tree[id].tag; 
  tree[id].tag = 0;
}
void pushUp(int id){
  tree[id].color = tree[id<<1].color | tree[id<<1|1].color;
}

void make(int id, int l, int r){
  if(l == r){tree[id].color = 1; tree[id].tag = 0; tree[id].l = l; tree[id].r = r; return;}  
  int mid = (l + r) >> 1;
  make(id << 1, l, mid);
  make(id << 1|1, mid+1, r);
  tree[id].l = l; tree[id].r = r; tree[id].tag = 0;
  pushUp(id); 
}

void update(int id, int l, int r, int col){
 // printf("%d, %d, %d\n", tree[id].l, tree[id].r, col);
  if(tree[id].l >= l && tree[id].r <= r){
    tree[id].color = 1 << (col-1); tree[id].tag = 1;
    return;
  }
  if(tree[id].tag != 0) pushDown(id);
  int mid = (tree[id].l + tree[id].r) / 2;
  if(l <= mid)
    update(id << 1, l, r, col);
  if(r > mid)
    update(id << 1 |1, l, r, col);
  pushUp(id);
}

int query(int id, int l, int r){
  if(tree[id].l >= l && tree[id].r <= r){return tree[id].color;}

  if(tree[id].tag != 0) pushDown(id);
  int mid = (tree[id].l + tree[id].r) /2;
  int ans = 0;
  if(l <= mid)
    ans = ans | query(id << 1, l, r);
  if(r > mid)
    ans = ans | query(id <<1 |1, l, r);
  return ans;
}


signed main(){
  int L, T, O; int A, B, C; int t;
  char c[2];
  scanf("%d %d %d", &L, &T, &O);
  make(1, 1, L);
  for(int i = 0; i < O; i++){
    scanf("%s", c);
    if(c[0] == 'C'){
      scanf("%d %d %d", &A, &B, &C);
      if(A > B) {swap(A,B);} 
      update(1, A, B, C);
    }
    else{
      scanf("%d %d", &A, &B);
      if(A > B) {swap(A,B);} 
      int res = query(1, A, B);
      int ans = 0;
      for(int s = 0; s < T; s++){
        ans += (res >> s) & 1;
      }
      printf("%d\n",ans);
    }
  }
  return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值