ACM博客_kuangbin 新博客kuangbin.org
人一我百,人十我万!追逐青春的梦想,怀着自信的心,永不放弃! by kuangbin 新博客 kuangbin.org
ACM HDU 1157 Who’s in the Middle (完全的水题,排序找中值的)
Who’s in the Middle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3360 Accepted Submission(s): 1646
Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
* Line 1: A single integer N
- Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
* Line 1: A single integer that is the median milk output.
Sample Input
5 2 4 1 3 5
Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
Source
USACO 2004 November
import java.util.Arrays;
import java.util.Scanner;
public class Main{
/**
* @param args
*/
static int a[]=new int[10010];
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner scan=new Scanner(System.in);
while(scan.hasNext()){
int n=scan.nextInt();
for(int i=0;i<n;i++){
a[i]=scan.nextInt();
}
Arrays.sort(a,0,n);
System.out.println(a[n/2]);
}
}
}