hdu1024 Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25587    Accepted Submission(s): 8858


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
      
      
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
      
      
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 

题目的大致意思:给定一个数组题目,求m个互不相交子序列的和最大值问题。

解题思路:涉及最值问题通常用到动态规划,这题也一样。用状态dp[i][j]表示前j个数在选择第j个数的前提下选取其中的i段(当然要满足互不相交)的最大值,第j个数可以包含在第i组里,也可以独立成组(第i段只有一个数),此时有状态转移方程dp[i][j]=max(dp[i][j-1]+a[j],max(dp[i-1][k]+a[j])),0<k<j.注意到n的限定范围是1~1000,000,m的限定范围未知,一不小心就有可能爆内存,可以采用滚动数组的方法优化内存。时间复杂度为n^2*m,n过大肯定会超时,可以这样优化max(dp[i-1][k]就是上一组0、1……j-1的最大值,我们可以在每次计算dp[i][j]的时候记录下前j个的最大值用数组保存下来,这样时间复杂度为n*m。

AC代码:

#include<stdio.h>
#include<string.h>
#define Maxn 1000000
#define INT 0x7fffffff
#define max(a,b) ((a>b)?a:b)
int a[Maxn+10];
int dp[Maxn+10];
int upper[Maxn+10];
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n)){
        int i,j,maxx;
        for(i=1;i<=n;i++) scanf("%d",&a[i]);
        memset(dp,0,(n+1)*sizeof(dp[0]));
        memset(upper,0,(n+1)*sizeof(upper[0]));
        for(i=1;i<=m;i++){
            maxx=-INT;
            for(j=i;j<=n;j++){
                dp[j]=max(upper[j-1]+a[j],dp[j-1]+a[j]);
                upper[j-1]=maxx;
                maxx=max(maxx,dp[j]);
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值