Asteroids POJ3041 二分图最小顶点覆盖

1.题目原文

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20663 Accepted: 11224

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

2.解题思路

利用攻击方法只有两种的特点,我们可以将上述问题按如下方法转换成图。
把光束当作图的顶点,而把小行星当作连接对应光束的边。这样转换之后,光束的攻击方案对应着一个顶点集合S,而要求攻击方案能够摧毁所有的小行星,也就是图中的每一条边都至少有一个属于S的端点。这样一来,问题就转化为求最小的满足上述要求的顶点集合S。
这就是最小顶点覆盖问题。最小顶点覆盖问题通常是NP困难的,但是在二分图中,最小顶点覆盖等于最大匹配。事实上,本题中的所有顶点都可以分成水平和竖直方向的攻击选择两类,而每颗小行星对应的边都分别于一个水平方向和竖直方向的顶点相连,即是二分图。
所以,运用二分图最大匹配算法即可迎刃而解。

3.AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
#include<utility>
#include<queue>
using namespace std;
#define MAX_K 10005
//二分图匹配模板
#define MAX_V 1005

int V;//顶点数
vector<int> G[MAX_V];//图的邻接表表示
int match[MAX_V];//所匹配的顶点
bool used[MAX_V];//DFS中用到的访问标记

//向图中增加一条连接u和v的边
void add_edge(int u,int v)
{
    G[u].push_back(v);
    G[v].push_back(u);
}

//通过DFS寻找增广路
bool dfs(int v)
{
    used[v]=true;
    for(int i=0;i<G[v].size();i++){
        int u=G[v][i],w=match[u];
        if(w<0||!used[w]&&dfs(w)){
            match[v]=u;
            match[u]=v;
            return true;
        }
    }
    return false;
}

//求解二分图的最大匹配
int bipartite_matching()
{
    int res=0;
    memset(match,-1,sizeof(match));
    for(int v=0;v<V;v++){
        if(match[v]<0){
            memset(used,0,sizeof(used));
            if(dfs(v)){
                res++;
            }
        }
    }
    return res;
}
//二分图匹配模板

int N,K;
int R[MAX_K],C[MAX_K];

void solve()
{
    V=2*N;
    for(int i=0;i<K;i++){
        add_edge(R[i]-1,N+C[i]-1);
    }
    printf("%d\n",bipartite_matching());
}
int main()
{
    scanf("%d%d",&N,&K);
    for(int i=0;i<K;i++){
        scanf("%d%d",&R[i],&C[i]);
    }
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值