Smallest Difference(poj 2718)二进制枚举+全排列

来自《挑战程序设计竞赛》

1.题目原文

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8583 Accepted: 2354

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

Source


2.解题思路

将一个数分成两个数,这两个数的数字顺序可以任意变化,不能有前导0,求这两个数差值的最小值。
显然有n个数,要使差值最小,必然一个数长n/2,一个数长n-n/2.
可以利用二进制枚举(bitset!!!),把一个数切割成两个整数,注意有些情况要舍去(长度不是n/2的,前导为0但不是一位数的)。
这时候已经切割好s1和s2.然后对这两个数进行全排列,就可以的得到所有情况,比较取最小值即可。
学到了好多关于STL的东西……

3.AC代码

#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#include<cmath>
#include<bitset>
using namespace std;

int main()
{
    int n;
    cin>>n;
    cin.ignore();
    while(n--){
        string all;
        getline(cin,all);
        all.erase(remove(all.begin(),all.end(),' '),all.end());//删除空格
        int length=all.size();
        int cut=length/2;
        int permute=1<<length;
        int result=0x7fffffff;
        do{
            bitset<10> used=static_cast<bitset<10> >(permute);
            string s1,s2;
            for(int i=0;i<length;i++){
                if(used[i]){
                    s1+=all[i];
                }
                else{
                    s2+=all[i];
                }
            }
            if(s1.size()!=cut){
                continue;
            }
            if(s1[0]=='0'&&s1.size()>1){
                continue;
            }
            //s1,s2已经枚举出来了
            //穷举它们
            do{
                int n1=atoi(s1.c_str());//将字符串转化成整数
                do{
                    if(s2[0]=='0'&&s2.size()>1){
                        continue;
                    }
                    int n2=atoi(s2.c_str());//将字符串转化成整数
                    int dif=abs(n1-n2);
                    //cout<<s1<<" "<<s2<<"dif:"<<dif<<"result:"<<result<<endl;
                    result=min(dif,result);
                }while(next_permutation(s2.begin(),s2.end()));//全排列

            }while(next_permutation(s1.begin(),s1.end()));

        }while(--permute);

        cout<<result<<endl;
    }
    return 0;
}

有关cin.ignore()的参考 http://blog.sina.com.cn/s/blog_868a5fbd0100vz9l.html也可直接查看API
英语不好,真心不行╮(╯_╰)╭。
再次遇到G++超时,C++却AC的情况。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值