M - Physical Examination

WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er…… There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.

The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.
Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
Sample Input
5
1 2
2 3
3 4
4 5
5 6
0
Sample Output
1419

Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue,
169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his
120-core-parallel head, and decided that this is the optimal choice.

题解:
此题只有两个注意点

第一个注意点:
此题不是单独按等待时间排,也不是纯粹按每秒钟增加的等待秒数排序
在这里插入图片描述

第二个注意点:
mod 365×24×60×60.

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;
typedef long long ll;
const ll mod = 31536000;
#define maxn 100005

typedef struct {
	ll a;
	ll b;
}st;

st stu[maxn];

bool myCompare(st aa, st bb) {
	if (aa.b * bb.a == bb.b * aa.a) {
		return aa.b > bb.b;
	}
	else
		return aa.b* bb.a > bb.b* aa.a;
}

int main() {
	std::ios::sync_with_stdio(false), cin.tie(0), cout.tie(0);
	ll n;
	while (cin >> n) {
		if (n == 0) {
			break;
		}
		ll sum = 0;
		for (ll i = 0; i < n; i++) {
			cin >> stu[i].a >> stu[i].b;
		}
		sort(stu, stu + n, myCompare);
		for (ll i = 0; i < n; i++) {
			if (i == 0) {
				sum += stu[i].a;
			}
			else {
				sum += (sum * stu[i].b)%mod;
				sum += stu[i].a%mod;
			}
		}
		cout << sum%mod << endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

veit sun

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值