B - Sum of Consecutive Prime Numbers

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.
Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.
Sample Input
2
3
17
41
20
666
12
53
0
Sample Output
1
1
2
3
0
0
1
2

题解:
尺取法
使用尺取法时要注意,区间如何移动,我们要选取的是什么样的区间

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int prime[10005];
bool IsPrime(int n){
    int sum=0;
    for(int i=2;i<n;i++){
        if(n%i==0){
            sum++;
            break;
        }
    }
    if(sum==0){
        return true;
    }
    else{
        return false;
    }

}
int main(){
    std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
    int cnt=0;
    for(int i=2;i<=10000;i++){
        if(IsPrime(i)){
            prime[cnt++]=i;
        }
    }
    prime[cnt]=INF;
    //cnt最后的结果存的是素数的个数
    //cout<<prime[cnt-1]<<endl;
    //cout<<prime[cnt-2]<<endl;
    int n;
    while(cin>>n){
        int sum=0;//和
        int st=0,en=0;//左右端点
        int ans=0;//个数
        if(n==0){
            break;
        }
        int end=cnt;
        //end为区间右端点
        while(1){
            while(en<=end&&sum<n){
                sum+=prime[en++];
            }
            if(sum<n){
                break;
            }
            else if(sum==n){
                ans++;
            }
            sum-=prime[st++];
        }
        cout<<ans<<endl;

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

veit sun

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值