HDU1047.Integer Inquiry

HDU1047.Integer Inquiry(大数求和)
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
This supercomputer is great,’’ remarked Chip. I only wish Timothy were here to see these results.’’ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
Sample Input
1
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670

题解:
简单大数
令我疑惑一点就是不知道原题中,1和下面的三行字符串中间为什么会有两个换行

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>

using namespace std;

int sum[101];//用来装最终相加的结果
int num[101];//用来存

int main(){
    int t;
    cin>>t;
    while(t--){
        memset(sum,0,sizeof(sum));
        string s;
        while(cin>>s){
            memset(num,0,sizeof(num));
            if(s[0]=='0'){
                break;
            }
            int k=0;
            for(int i=s.length()-1;i>=0;i--){
                num[k++]=s[i]-'0';
            }
            int flagi=0;
            for(int i=0;i<=100;i++){
                int a=sum[i]+num[i]+flagi;
                if(a>9){
                    flagi=1;
                }
                else{
                    flagi=0;
                }
                sum[i]=a%10;
            }

        }
        int tt=0;
        for(int i=100;i>=0;i--){
            if(sum[i]!=0){
                tt=i;
                break;
            }
        }
        for(int i=tt;i>=0;i--){
            cout<<sum[i];
        }
        cout<<endl;
        if(t!=0){
            cout<<endl;
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

veit sun

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值