HDU 4442 Physical Examination

Physical Examination

Problem Description

WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.

Input

There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.

Output

For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.

Sample Input

5 1 2 2 3 3 4 4 5 5 6 0

Sample Output

1419

Hint

In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.


解题思路:

假设两个队列X,Y。

我们考虑先排哪一个队列,我们花费更少时间呢?

(1)如果我们先排X队的话,T_{1}=X.a+Y.a+X.a*Y.b

(2)如果我们先排Y队的话,T_{2}=Y.a+X.a+Y.a*X.b

由数学关系我们看出我们应该通过比较 X.a*Y.b 和 X.b*Y.a 的大小关系来确定我们先入哪个队列。

于是,这题可以通过排序取得正确答案。

代码实现:

/*
156MS	2780K
*/ 
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node{
	long long a,b;
};
const int mod=365*24*60*60;
bool cmp (const Node x,const Node y)
{
	return x.a*y.b<x.b*y.a; //不要在这里取模,会WA 
}
int main()
{
	int n;
	while (~scanf ("%d",&n)&&n)
	{
		Node g[100005];
		for (int i=0;i<n;i++)	
		{
			scanf ("%lld%lld",&g[i].a,&g[i].b);
		}
		sort(g,g+n,cmp);
		long long sum=0;
		for (int i=0;i<n;i++)
		{
			sum=(sum+(g[i].a+(sum)*(g[i].b)))%mod;//计算时间 
		}
		printf ("%lld\n",sum);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值