【CODE[VS]】1201--最小数和最大数

题目描述 Description

输入n个数,n<=100,找到其中最小的数和最大的数

输入描述 Input Description

第一行一个整数n
接下来一行n个整数,每个整数不超过231 -1

输出描述 Output Description

最小和最大的数

样例输入 Sample Input

4
1 2 3 4

样例输出 Sample Output

1 4

数据范围及提示 Data Size & Hint


代码
#include <iostream>
using namespace std;

int main(){
    int n,t,max=-1,min=1<<30;
    cin>>n;
    if(n>=1&&n<=100){
        while(n--){
            cin>>t;
            if(t>max) max=t;
            if(t<min) min=t;
        }
        cout<<min<<" "<<max;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值