【NEEPU OJ】1023--Knight Moves

Description

Alice is doing research on the Traveling Knight Problem(TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. She thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the”difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a…h) representing the column and a digit (1…8) representing the row on the chessboard.

Output

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

输入样例 1

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

输出样例 1

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

来源

UVa


代码
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int dx[] = {-2, 2, -2, 2, 1, 1, -1, -1};
const int dy[] = {1, 1, -1, -1, -2, 2, -2, 2};
int vis[10][10];

struct node{
	int x, y;
}start, over;

int bfs(){
    if(start.y == over.y && start.x == over.x) return 0;
    memset(vis, 0, sizeof(vis));
	queue<node> q;
	int i;
	q.push(start);
	while(!q.empty()){
	    node t1 = q.front();
	    q.pop();
	    for(i = 0; i < 8; i++){
	        node t2;
	        t2.x = t1.x + dx[i];
	        t2.y = t1.y + dy[i];
	        if(t2.x >= 1 && t2.x <= 8 && t2.y >= 1 && t2.y <= 8 && !vis[t2.y][t2.x]){
	        vis[t2.y][t2.x] = vis[t1.y][t1.x] + 1;
	        if(t2.y == over.y && t2.x == over.x) return vis[t2.y][t2.x];
	        q.push(t2);
	        }
	    }
	}
	return -1;
}

int main(){
	char sy, oy;
	while(~scanf("%c%d %c%d%*c", &sy, &start.x, &oy, &over.x)){
	    start.y = sy - 96;
	    over.y = oy - 96;
	    printf("To get from %c%d to %c%d takes %d knight moves.\n", sy, start.x, oy, over.x, bfs());
	}
	return 0;
}
杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值