【HDOJ】6441--Find Integer

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

Recommend

chendu


代码
#include <cstdio>
using namespace std;

int main(){
    int t, n, a, k;
    int res1, res2;
    scanf("%d", &t);
    while(t--){
        scanf("%d %d", &n, &a);
        if(n > 2 || n == 0){
            puts("-1 -1");
        }
        else if(n == 1){
            printf("1 %d\n", a + 1);
        }
        else if(n == 2){
            if(a & 1){
                k = 1; //  k={1,a^2的所有小于a的因子}
            }
            else{
                k = 2; //  k={a^2 / 2的所有小于a的偶数因子}
            }
            res1 = (a * a / k - k) / 2;
            res2 = (a * a / k + k) / 2;
            printf("%d %d\n", res1, res2);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值