Problem Description
people in USSS love math very much, and there is a famous math problem .
give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.
Input
one line contains one integer T;(1≤T≤1000000)
next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)
Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);
else print two integers -1 -1 instead.
Sample Input
1
2 3
Sample Output
4 5
Source
2018中国大学生程序设计竞赛 - 网络选拔赛
Recommend
chendu
代码
#include <cstdio>
using namespace std;
int main(){
int t, n, a, k;
int res1, res2;
scanf("%d", &t);
while(t--){
scanf("%d %d", &n, &a);
if(n > 2 || n == 0){
puts("-1 -1");
}
else if(n == 1){
printf("1 %d\n", a + 1);
}
else if(n == 2){
if(a & 1){
k = 1; // k={1,a^2的所有小于a的因子}
}
else{
k = 2; // k={a^2 / 2的所有小于a的偶数因子}
}
res1 = (a * a / k - k) / 2;
res2 = (a * a / k + k) / 2;
printf("%d %d\n", res1, res2);
}
}
return 0;
}