[dij]POJ#2253 Frogger 解题笔记

题面

传送门
Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 90898 Accepted: 27297

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意

给若干石头坐标,从起点到终点的若干路径中要求找到最大跳跃距离最小的,输出那个最小的路径中的最大跳跃距离(下称青蛙距离)

解题思路

这题其实dij,floyd,spfa都能跑,我就直接选了dij。本质上是一个变形的最短路问题,即用青蛙距离代替了最短路的距离,不过松弛操作也得相应改变。

AC代码

#include<cstdio>
#include<vector>
#include<queue>
#include<cmath>
#include<cstring>
#define re register
using namespace std;

struct node{
	int pos,dis;
	node(int pos_,int dis_):
		pos(pos_),dis(dis_){}
	bool operator< (const node &x) const
	{
		return x.dis<dis;
	}
};
struct edge{
	int node,weight;
	edge(int node_,int weight_):
		node(node_),weight(weight_){}
};
const int maxn=201;
int dis[maxn],n,cx[maxn],cy[maxn],cnt = 1;
bool visited[maxn];
vector<edge> e[maxn];
inline void dijskstra(int s)
{
	priority_queue<node> Q;
	for(int i=1;i<=n;++i)dis[i]=1e9;
	dis[s]=0;
	Q.push(node(s,0));
	while(!Q.empty())
	{
		node tmp=Q.top();
		Q.pop();
		if(tmp.dis!=dis[tmp.pos])continue;
		for(vector<edge>::iterator it=e[tmp.pos].begin();it!=e[tmp.pos].end();++it)
		{
			int to=it->node,weight=it->weight;
			if(dis[to]>weight && dis[to]>dis[tmp.pos])
			{
				dis[to]=max(dis[tmp.pos],weight);
				Q.push(node(to,dis[to]));
			}
			
		}
	}
}
inline int cd(int a, int b){
    return (cx[a]-cx[b])*(cx[a]-cx[b])+(cy[a]-cy[b])*(cy[a]-cy[b]);
}
int main()
{
	while (~scanf("%d",&n) && n!=0){
        memset(visited,0,sizeof(visited));
        for(re int i=1,w;i<=n;++i)
        {
            scanf("%d%d",&cx[i],&cy[i]);
            for(int j=1;j<i;j++){
                w= cd(i,j);
                e[i].push_back(edge(j,w));
                e[j].push_back(edge(i,w));
            }
        }
        dijskstra(1);
        printf("Scenario #%d\n",cnt++);
        printf("Frog Distance = %.3f\n\n",sqrt((double)dis[2]));
        for(int i = 1; i <= n ; i++)e[i].clear();
    }
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

McDuck_Spirit

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值