Farthest Nodes in a Tree

Farthest Nodes in a Tree

Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output
For each case, print the case number and the maximum distance.

Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100
Case 2: 80

题意:给出一棵树,n个顶点,n-1 条边,给出每条边的权值,问树上的任意两点的最大距离是多少

题解:树的直径就像化学中高分子链式结构中的主链,而从任意节点出发到达一个与它最远的点必是这条主链的一个端点,设为S,再从这个端点出发,找距离它最远的点必是必是主链的另一端点,设为T,则S-T就是树的直径。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN =30000+10;
struct Edge
{
    int from,to,val,next;
};
Edge edge[MAXN*2];
int head[MAXN];//每个节点的头“指针 ” 
int edgenum;//总边数 
void init()
{ 
    memset(head, -1, sizeof(head)); 
    edgenum = 0; 
}
void addEdge(int u, int v, int w) 
{
    edge[edgenum].from = u;
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}
int ans;//记录最后的结果 
int Tnode;//记录S-T的端点 
int dist[MAXN];//以该节点结尾的最长路 
bool vis[MAXN];//标记节点是否被访问过 
int n;
void BFS(int s)
{
    memset(dist, 0, sizeof(dist));
    memset(vis, 0, sizeof(vis));
    queue<int> Q; 
    Q.push(s); 
    vis[s] = 1; dist[s] = 0;//起点 
    ans = 0;
    while(!Q.empty()) 
    {
        int u = Q.front(); Q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next) 
        {
            int v = edge[i].to;
            if(!vis[v]) 
            {
                if(dist[v] < dist[u] + edge[i].val) 
                {
                    dist[v] = dist[u] + edge[i].val;
                }
                 vis[v] = 1;
                 if(ans<dist[v])
                 {
                    ans=dist[v];//这个是最长的距离 
                    Tnode=v;//距离当前点最远的点的编号 
                 }                
                Q.push(v);
            }
        }
    }         
}
int main()  
{  
    int t,n,i,k,a,b,c;  
    scanf("%d",&t);  
    for(k=1;k<=t;k++)  
    {  
        init();  
        scanf("%d",&n);  
        for(i=0;i<n-1;i++)  
        {    
            scanf("%d%d%d",&a,&b,&c);  
            addEdge(a,b,c);
            addEdge(b,a,c);  
        }  
        BFS(0);//搜索出起点的值 
        BFS(Tnode);//搜索出最远距离 
        printf("Case %d: %d\n",k,ans);  
    }  
    return 0;  
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值