E - E HDU - 3280(暴力枚举)

E - E HDU - 3280(暴力枚举)

An equal sum partition of a sequence of numbers is a grouping of the
numbers (in the same order as the original sequence) in such a way
that each group has the same sum. For example, the sequence: 2 5 1 3
3 7 may be grouped as: (2 5) (1 3 3) (7) to yield an equal sum of
7.

Note: The partition that puts all the numbers in a single group is an
equal sum partition with the sum equal to the sum of all the numbers
in the sequence.

For this problem, you will write a program that takes as input a
sequence of positive integers and returns the smallest sum for an
equal sum partition of the sequence. Input The first line of input
contains a single integer P, (1 ≤ P ≤ 1000), which is the number of
data sets that follow. The first line of each data set contains the
data set number, followed by a space, followed by a decimal integer M,
(1 ≤ M ≤ 10000), giving the total number of integers in the sequence.
The remaining line(s) in the dataset consist of the values, 10 per
line, separated by a single space. The last line in the dataset may
contain less than 10 values. Output For each data set, generate one
line of output with the following values: The data set number as a
decimal integer, a space, and the smallest sum for an equal sum
partition of the sequence.

Sample Input
3
1 6
2 5 1 3 3 7
2 6
1 2 3 4 5 6
3 20
1 1 2 1 1 2 1 1 2 1
1 2 1 1 2 1 1 2 1 1
Sample Output
1 7
2 21
3 2
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
void fre() { freopen("A.txt","r",stdin), freopen("Ans.txt","w",stdout); }
#define ll long long 
const int mxn = 10005;
const int INF = 0x3f3f3f3f;
int ar[mxn];


int main()
{
    /* fre(); */
    int t;
    scanf("%d", &t);
    while(t --)
    {
       int Case, n; 
       ll S = 0;
       scanf("%d %d", &Case, &n);
        for(int i = 1; i <= n; i ++)
            scanf("%d", &ar[i]), S += ar[i];
        ar[n + 1] = 0;
        for(int i = 1; i <= n; i ++)
        {
            ll val = 0; 
            for(int j = 1; j <= i; j ++)
                val += ar[j];
            if(val == 0 || S % val == 0)
            {
                int tem = 0;
                int flag = 1;
                for(int k = i + 1; k <= n + 1; k ++)
                {
                    tem += ar[k];
                    if(tem == val)
                        tem = 0;
                    else if(tem > val)
                    {
                        flag = 0;
                        break;
                    }
                }
                if(flag)
                {
                    printf("%d %lld\n", Case, val);
                    break;
                }
            }
        }
    }


    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值