poj 2488 A Knight's Journey(DFS)

题目链接:http://poj.org/problem?id=2488

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44457 Accepted: 15103

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



题意:给你一个棋盘,就是只能走 “日”,象棋的马,求走完所有格子的最小字典序,列ABCD,行1234

解析:就是DFS搜索一下,求出最小的字典序


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#define N 9
using namespace std;
const int INF = 0x3f3f3f3f;

int nx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int ny[8] = {-1, 1, -2, 2, -2, 2, -1, 1};

int mp[N][N], f, m, n;
char ans[N*N], tm[N*N];

void dfs(int i, int j, int cnt)
{
    if(cnt == m*n)
    {
        tm[cnt*2] = '\0';
        if(!f || strcmp(tm, ans) < 0)
        {
            strcpy(ans, tm);
            f = 1;
        }
    }
    for(int k = 0; k < 8; k++)
    {
        int x = i + nx[k];
        int y = j + ny[k];
        if(x < 1 || x > m || y < 1 || y > n) continue;
        if(mp[x][y]) continue;
        mp[x][y] = 1;
        tm[cnt * 2] = y + 'A' - 1;
        tm[cnt * 2 + 1] = x + '0';
        dfs(x, y, cnt + 1);
        mp[x][y] = 0;
    }
}

int main()
{
    int t, cnt = 0;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &m, &n);
        memset(mp, 0, sizeof(mp));
        f = 0;
        ans[0] = '\0';
        mp[1][1] = 1;
        tm[0] = 'A';
        tm[1] = '1';
        dfs(1, 1, 1);
        printf("Scenario #%d:\n", ++cnt);
        if(f) puts(ans);
        else puts("impossible");
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值