poj 3278 队列的经典题目 且行且珍惜----

C - Catch That Cow
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
这道题已经做了好多遍了,昨天下午做的时候一样的代码在c++上交是re了,在g++上交的时候就wa了,而且有重新打了一个一模一样的,然后就过了,真的是一抹一样的代码,现在还郁闷。这道题的解题思路就是利用广搜把每个点的跳的下一个点的情况都枚举出来,这样找他的最短时间,当然,先出来的就是最短的时间。这道题我收获最大的是队列里的数据不随你刚开始赋值于它的变量的变化而变化,他就是一个常值。
<pre name="code" class="html">#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
int Star, End;
int  v[200001];

struct node
{
    int step, s;
};
int bfs(int a, int b)
{
    queue<node>q;
    struct node p,x,tmp;
    p.s=a;
    p.step=0;
    memset(v,0,sizeof(v));
    v[a]=1;
    q.push(p);
    while(!q.empty())
    {
        x = q.front();
        q.pop();
        if(x.s == b)
        {
            return x.step ;
        }
        if(x.s <= b && !v[x.s + 1])
        {
            v[x.s + 1] = 1;
            p.s = x.s + 1;
            p.step = x.step + 1;
            q.push(p);
        }
        if(x.s >= 1 && !v[x.s - 1]) //要保证减1后有意义,所以要X >= 1
        {
            v[x.s - 1] = 1;
            p.s = x.s - 1;
            p.step = x.step + 1;
            q.push(p);
        }

        if(x.s <= b && !v[x.s * 2])
        {
            ///node temp;
            v[x.s * 2] = 1;
            p.s = 2 * x.s;
            p.step = x.step + 1;
            q.push(p);
        }
    }
}
int main()
{
    while(scanf("%d%d",&Star,&End)!=EOF)
    {
        int ans=bfs(Star,End);
        printf("%d\n",ans);
    }
}

 
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值