hdu 5980

Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 90    Accepted Submission(s): 54


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
  
  
3 97 24929 100
 

Sample Output
  
  
3
 

Source
 

这道题是个签到题, 但是我也错的很离谱就是数组没有初始化为0, 但是我有记得我初始化了呀 ,郁闷!
这道题的题意就给你一个数字大小在2的32次方以下,  也就是说开个50左右的数组就行了, 然后判断从左边第一位开始直到第八位按照十进制的方法加起来是否等于97;
每八位是一个数字 ,统计一下有几个97;
ac代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<math.h>

using namespace std;
int sp[2016][2016];
int sq[2016][2016];

int main()
{
    int t,i, j, sum, ans, q;
    long long n, k;
    int s[100];
    while(scanf("%d",&t)!=EOF)
    {
        ans=0;
        while(t--)
        {
            memset(s,0,sizeof(s));
            scanf("%lld",&n);
            k=0;
            while(n>0)
            {
                s[k]=n%2;
                n/=2;
                k++;
            }
            for(i=0;i<k;i+=8)
            {
                q=1;sum=0;
                for(j=i;j<=i+7;j++)
                {
                    sum+=q*s[j];
                    q*=2;
                }
                if(sum==97)
                    ans++;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值