POJ 3278:Catch That Cow 抓住那头牛

16 篇文章 0 订阅
12 篇文章 0 订阅

POJ 3278:Catch That Cow 抓住那头牛


总时间限制: 
2000ms 
内存限制: 
65536kB
描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入
Line 1: Two space-separated integers:  N and  K
输出
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
样例输入
5 17
样例输出
4
提示
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目分析:
Finding the shortest path,采用广度搜索BFS的方法。
注意分析题目:
Farmer John 的位置是N, cow 牛的位置是 K;
action只有3种,+1,-1,*2; 没有 “除以2”。

所以当N>K,时,只能执行-1 action。 即 如N-K,最短steps= K-N。

当N<K时,
N>0; 可以执行-1 action。
N<K; 可以执行+1 action
2*N<K+parameter , 可以执行 *2 action。 //这里不太严谨,没有给出数学证明, parameter=MAX-K, 如下面代码所示。关键是给一个任意的N<K, N通过+1,*2 actions最多可以通过多少step到达K。



样例代码:
/*
广度优先搜索,重要的是剪枝和标记访问过的路径。
所谓的剪枝,也可以理解为生成每一个子节点的条件;所谓条件限制越严谨,剪枝效果越好。

*/
#include <iostream>
#include <cstring>
#include <queue>

using namespace std;

const int MAX=100020; // 这个MAX的设定并不太严谨
int visited[MAX]={0};

int main()
{
	int n,k;
	while (cin>>n>>k){
		if( n > k ){ 
			cout<<n-k<<endl;
			continue;
		}
		memset(visited,0,sizeof(visited)); 
		queue<int> q;
		q.push(n);
		int t=0;
		while( !q.empty() ){
			t = q.front();
			q.pop();

			if(t == k){
				break;
			}
			if( t < k && !visited[t+1] ){ // 当t>k时,不执行+1 action
				q.push(t+1); 
				visited[t+1] = visited[t] + 1;
			}

			if( t > 0 && !visited[t-1] ){ //
				q.push(t-1);
				visited[t-1] = visited[t] + 1;
			}
			
			if( 2*t < MAX && !visited[2*t] ){ //此处不太严谨,如上讨论
				q.push(2*t);
				visited[2*t] = visited[t] +1;
			}
		}
		cout<<visited[t]<<endl;
	}

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值