POJ 3087 Shuffle'm Up 简单的模拟题

Shuffle'm Up
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips,S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (Athrough H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

这道题最我真的用了很多的方法来写第一次用的是是用一个二维的字符串数据把每次出现洗牌的新组合储存下来然后用for循环过一遍,查看是否有重复的,如果有重复的直接判断出该组合是无解的,第二种方法是用两个一维的字符串存下来刚开始开头和结束的数组然后判断是否会再次出现,如果再次出现的时候就是说明该结果又出现死循环了。 第三种方法是你直接把第一个两套牌组合在一起的储存起来。然后看他是否再次出现;这道题的本质就是理解懂题意,标记刚开始的洗牌的结果,看以后是否还会出现  
题目大意:
已知两堆牌s1和s2的初始状态, 其牌数均为c,按给定规则能将他们相互交叉组合成一堆牌s12,再将s12的最底下的c块牌归为s1,最顶的c块牌归为s2,依此循环下去。给定输入s1和s2的初始状态 以及 预想的最终状态s12。


问s1 s2经过多少次洗牌之后,最终能达到状态s12,若永远不可能相同,则输出"-1"。

AC代码:


     
     
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
using namespace std;
char mapp [ 100000 ][ 110 ];//存储每次发牌时的字符串
int main ()
{
char s1 [ 110 ], s2 [ 110 ], ss [ 250 ], s3 [ 250 ];
int i , j , n , m , step , t , state , p ;
scanf ( "%d" ,& n );
t = 1 ;
while ( n --)
{
scanf ( "%d" ,& m );
getchar ();
gets ( s1 );
gets ( s2 );
gets ( ss );
memset ( mapp , 0 , sizeof ( mapp ));
step = 0 ; p = 0 ;
while ( 1 )
{
int k = 0 ;
state = 0 ;//标记判断是否结束循环
for ( i = 0 ; i < m ; i ++)
{
s3 [ k ++]= s2 [ i ];
s3 [ k ++]= s1 [ i ];
}
s3 [ k ]= ' \0 ' ;
if ( strcmp ( s3 , ss )== 0 )
{
state = 1 ;
break ;
}
for ( i = 0 ; i < p ; i ++)
if ( strcmp ( s3 , mapp [ i ])== 0 )//跑一遍循环查找是否存在相同的
{
state =- 1 ;
break ;
}
if ( state == 0 )
{
for ( i = 0 , j = m ; i < m ; i ++, j ++)
{
s1 [ i ]= s3 [ i ];
s2 [ i ]= s3 [ j ];
}
strcpy ( mapp [ p ], s3 );
p ++;
step ++;
}
else
break ;
}
if ( state == 1 )
printf ( "%d %d \n " , t , step +1 );
else
printf ( "%d -1 \n " , t );
t ++;
}
return 0 ;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值