poj 3126 Prime Path(简单bfs)

21 篇文章 1 订阅


Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17872 Accepted: 10065

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
题意:由一个四位数素数变成另一个四位数素数,每次只能改变一个数字,而且改变之后的每个数必须也为素数,问最短几步就可以变到要求的素数

思路:广搜,4个数字每个数字从0变到9,难点在与每次改变一个数字。。我一开始天真的开了个dir数组,里面是1000,100,10,1,-1000,-100,-10,-1每次+1减一。。但是可以进位。。。

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
const int maxn = 1e5 + 5;
int book[maxn], prime[maxn];
int dir[8] = {1, 10, 100, 1000};
struct node
{
    int num, step;
    node(int nn, int ss) :  num(nn), step(ss)  {}
    node() {}
};
void bfs(int s, int e)
{
    queue<node> q;
    q.push(node(s,0));
    book[s] = 1;
    while(q.size())
    {
        node p = q.front();
        q.pop();
        if(p.num == e)
        {
            printf("%d\n", p.step);
            return ;
        }
        for(int k = 0; k < 4 ; k++)
        {
            for(int i = 0; i <= 9; i++)
            {
                int tx = p.num - p.num / dir[k] % 10 * dir[k];  //这里是精髓
                tx = tx + dir[k]*i;
                if(!book[tx] && !prime[tx] && tx <= 9999 && tx >= 1000)  //这里如果不加后两个判断条件,可能会变成3位数两位数。。。0100,0010等
                {
                    q.push(node(tx, p.step+1));
                    book[tx] = 1;
                }
            }
        }
    }
    printf("Impossible\n");
}
int main()
{
    int t, a, b;
    for(int i = 2; i <= 10000; i++)
    {
        if(!prime[i])
        {
            for(int j = i * 2; j <= 10000; j += i)
                prime[j] = 1;
        }
    }
    scanf("%d", &t);
    while(t--)
    {
        memset(book, 0, sizeof(book));
        scanf("%d%d", &a, &b);
        bfs(a, b);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值