Find Small A
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 427 Accepted Submission(s): 220
Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤
ai
≤2^32 - 1) follow
Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
Sample Input
3 97 24929 100
Sample Output
3
思路:CillyB: % 256是看看后8位是多少, /= 256是去掉后8位,仔细想想 % 2^8其实就是后面8位的值(这一点记住吧) /= 就是 >> 8位
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(void)
{
int n;
while(cin >> n)
{
int ans = 0, t;
for(int i = 0; i < n; i++)
{
scanf("%d", &t);
while(t)
{
if(t%256 == 97) ans++;
t /= 256;
}
}
printf("%d\n", ans);
}
return 0;
}