HDU 5980 Find Small A(对二进制理解)

49 篇文章 0 订阅


Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 427    Accepted Submission(s): 220


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤  ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
  
  
3 97 24929 100
 

Sample Output
  
  
3
 
 题意:给N个数 每个数都可以拆开成一个32位的2进制 每八位一个字节  每个字节的2进制数换算成十进制的看有多少个97

思路:CillyB: % 256是看看后8位是多少, /= 256是去掉后8位,仔细想想 % 2^8其实就是后面8位的值(这一点记住吧) /= 就是 >> 8位

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(void)
{
    int n;
    while(cin >> n)
    {
        int ans = 0, t;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &t);
            while(t)
            {
                if(t%256 == 97) ans++;
                t /= 256;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值